升级Python2.7导致使用pip等命令安装模块失败

报错如下:

其实发生这个问题是因为:虽然你已经把Python升级到了2.7版本,但是pip仍然是原来的,版本,仍然在原来python的site-package里面

CentOS5环境下,默认是python2.4,site-package在

很多模块都被安装在这里。直接打pip,还是使用的原来的pip。所以我们的思路就是:应该在新的Python中安装pip,这样才不会报错。

这个问题遇到的人很多,但是解决的太少了,网上都是抄来抄去,都解决不了问题。最后还是在一外个国人的网站上找到了解决方案:

使用新版本的python来运行这个脚本,这个会自动安装出来一个easy_install,然后使用这个新的easy_install来安装pip就可以了!

安装生成的所有二进制文件,都是在你的PYTHON_HOME/bin/,因为我的是安装在/usr/local/python/,所以命令都在这里,以后再调用pip要使用绝对路径,或者做链接!

2.7的模块是在以下目录

 

附:脚本的原文

 

  3 comments for “升级Python2.7导致使用pip等命令安装模块失败

  1. 2019 年 4 月 17 日 at 05:43
  2. 2019 年 4 月 17 日 at 02:55
  3. 2019 年 4 月 17 日 at 02:52
    Your comment is awaiting moderation.

    You said this perfectly.
    http://cialismsnrx.com/
    cialis painful urination cialis 20 mg cialis kopen op internet cialis 20 mg
    cialis fuga venosa
    cialis generico forum
    cialis bestellen paypal
    cialis and nitrate therapy
    cialis siparis net
    take half of cialis

  4. 2019 年 4 月 17 日 at 02:11
  5. 2019 年 4 月 17 日 at 02:05
    Your comment is awaiting moderation.

    You explained that wonderfully!
    http://cialispego.com/
    do i need a prescription for cialis in mexico generic cialis can cialis be bought online generic cialis
    40 mg cialis generic
    does cialis ever expire
    cialis dali je stetan
    chewable cialis
    cialis annual sales 2011
    daily dose cialis for bph

  6. 2019 年 4 月 17 日 at 01:53
    Your comment is awaiting moderation.

    Seriously quite a lot of good advice.
    http://cialisttk.com/
    cialis hinta apteekki cialis online cialis online prices cheap cialis
    cialis kopen online
    cbip cialis
    cialis w aptece kosztuje
    cialis pagamento postepay
    remedio cialis preco
    cialis u apotekama beograd

  7. 2019 年 4 月 16 日 at 21:18
    Your comment is awaiting moderation.

    You made your point.
    http://cialismsnrx.com/
    viagra-cialis-levitra originali
    cheap cialis
    forum cialis 10 mg
    cheap cialis

  8. zealot
    2018 年 3 月 14 日 at 00:15

    您好! 本人初次涉及linux,遇到了与博主同样的问题,按照您这边的方法,copy脚本并运行 提示错误403 SSL is required。不知道该如何解决,希望阁下不吝赐教。

  9. 匿名
    2013 年 9 月 27 日 at 10:51

    测试评论功能

发表评论

电子邮件地址不会被公开。 必填项已用*标注